Función SI y SI anidados

La función SI es una función condicional de Excel que es muy útil en varios casos. Y más si la sabemos manejar correctamente y anidar.

La función SI exige tres parámetros:

  • La condición que debe verificarse, cumplirse
  • Lo que ocurre si se cumple
  • Lo que ocurre si no se cumple

Empecemos con un ejercicio sencillo pues partiendo de la edad de una persona debemos determinar si es mayor o menor de edad

Podemos las edades en unas celdas

Y a la derecha escribimos la primera función

=SI(A2<18;”MENOR”;”MAYOR”)

Estamos diciendo,

  • Condición: Edad < 18
  • Si SI se cumple, escribe MENOR
  • Si NO se cumple, escribe MAYOR

Si lo arrastramos nos da

Hagamos otro ejemplo para ver si una persona está activa o esta jubilada, suponiendo una edad de jubilación 65 año

Copiamos las edades y a su derecha ponemos la función

=SI(A8>=65;”JUBILADO”;”ACTIVO”)

Estamos diciendo

  • Condición: edad >= 65
  • Si SI se cumple, escribe JUBILADO
  • Si NO se cumple, escribe ACTIVO

Como vemos el chaval de 14 años consta como activo, y nos interesaría que pusiera MENOR.

Para ello debemos combinar, anidar dos SI

Copiamos las edades otra vez y ponemos la función

=SI(A14<18;”MENOR”;SI(A14>=65;”JUBILADO”;”ACTIVO”))

Estamos diciendo:

  • Condición: Edad < 18
  • Si SI se cumple, escribe MENOR
  • Si NO se cumple, empieza otra prueba lógica
    • Condición: Edad>=65
    • Si SI se cumple, escribe JUBILADO
    • Si NO se cumple, escribe ACTIVO

Y por supuesto cerramos los DOS paréntesis que hemos abierto

Hay que tener cuidado con los valores de la parte NO se cumple pues a veces nos puede dar resultados no esperados.

Imaginemos que tenemos una lista de empleados, y que hay una columna que indica con H o M si es hombre o mujer, pero queremos que salga la palabra entera

Creamos las celdas y ponemos

Como vemos el último valor es un error, a ver qué pasa

Ponemos la función si a la derecha de la primera celda

=SI(F2=”H”;”HOMBRE”;”MUJER”)

Estamos diciendo

  • Condición: la letra sea igual a una H
  • Si SI se cumple, escribe HOMBRE
  • Si NO se cumple, escribe MUJER

Si arrastramos vemos el resultado

La última fila nos ha puesto MUJER que no es el resultado esperado. Pero en pura lógica es correcto, hemos dicho si es H escribe HOMBRE y si no es H, o sea EN CUALQUIER otro caso escribe MUJER.

Esto lo podemos corregir con un SI anidado

=SI(F6=”H”;”HOMBRE”;SI(F6=”M”;”MUJER”;”DESCONOCIDO”))

Estamos diciendo

Estamos diciendo

  • Condición: la letra sea igual a una H
  • Si SI se cumple, escribe HOMBRE
  • Si NO se cumple, otra condición
    • Condición: si la letra es igual a M
    • Si SI se cumple, escribe MUJER
    • Si NO se cumple, escribe DESCONOCIDO

Así pues hay que ir con cuidado con los resultados de la prueba.

Por cierto hemos visto que da igual sea minúsculas que mayúsculas.

También hay que tener presente que si olvidamos el ultimo parámetro nos dará un valor falso

Ponemos la función

=SI(F8=”H”;”HOMBRE”)

Que como vemos no hay tercer parámetro y al aplicarla nos da

Pueden subir el ejercicio aquí  Funcion SI y SI anidado

Un comentario sobre “Función SI y SI anidados”

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.